RIPTIDE System Requirements for Version 3.0

Supported Operating Systems

  • Windows 7, 8, 10
  • Linux (Ubunto, CentOS, SUSE, Red Hat Enterprise)

Required Software

  • MATLAB® (R2010a through R2017a), Simulink®, Control System Toolbox, Simulink Coder
    • MATLAB®, Simulink®, and the Control System Toolbox are needed to develop control laws to be tested in RIPTIDE. Simulink Coder is needed to generate C code and the corresponding executable from the Simulink® blocks. The resulting executable is what’s actually run under RIPTIDE.
  • Windows: Microsoft Visual C++ 2010 (Express or above)
  • Linux: OSG, Qt